WTK 2.5.1 requires GLIBC_2.4 hack

been playing WTK but WTK 2.5.1 requires GLIBC_2.4
and I'm using opensuse 10.0 which has lower glibc :(

this is the hack found in sun forum:
  1. install wtk as usual
  2. cd wtk (where you install it)
  3. grep -ral GLIBC_2.4 bin | xargs perl -pe 's/GLIBC_2.4/GLIBC_2.2/g; s/\cTii\cM/\cRii\cM/g' -i~
  4. echo 'void __stack_chk_fail(void){void abort(); abort();}' | cc -x c - -shared -o bin/kludge.so
  5. LD_PRELOAD=`pwd`/bin/kludge.so ./bin/ktoolbar


Computer2 said…
wow hebat ...

saya benar2 tidak terpikir sama sekali. top

Popular posts from this blog

Ports to allow for whatsapp call

Setting open office u label tom & jerry

Tips Jika Mobil Anda Habis Bensin LOL!